Archivists Toolkit
  1. Archivists Toolkit
  2. ART-2627

Poor Performance and Missing Input Fields in the Assessment Module

    Details

    • Type: End-User Bug End-User Bug
    • Status: Closed Closed
    • Priority: High High
    • Resolution: Task complete
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: Core application
    • Labels:
      None

      Description

      Currently, database records are loaded then the Assessment dialog is displayed. This approach works fine for a few hundred records, but if there are thousands of assessment records to load then it can take a few minutes for the dialog to display. Unfortunately, during that time the user receives no feedback and thinks the program have froze.

      Also, there are two fields which are now missing ("User who created record" and "Date of Survey") in the user interface, which are part of the data model.

      A beta release (update 13) of the AT which addresses those issues can be downloaded from the link below:
      http://dlibdev.nyu.edu/~stevens/install.htm

        Activity

        Hide
        Annie Ross added a comment -
        Fixed in maintenance release 2.0, Update 13
        Show
        Annie Ross added a comment - Fixed in maintenance release 2.0, Update 13

          People

          • Assignee:
            Nathan Stevens
            Reporter:
            Nathan Stevens
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: